IP: dwominecraft.com

Latest DWO Minecraft News

Downgrade to 1.8 to play on DWO

29 February 2016

Minecraft 1.9 has now been released, so as always you need to downgrade to 1.8 to play on DWO!

When you open the launcher, press the 'Edit Profile' button beneath your username, and change the 'Use Version' box to 'release 1.8.9'.

We're hopeful this time around for a speedy upgrade, but all we can do is sit tight and wait for the technology to catch up, and we'll let you know once 1.9 comes to DWO.

MurreeyMurreey/